So and Shin Program 2016

I have to make some modifications in the program of Seo and Shin 2016. I am using the version of GAUSS 10.  I want to ask you about the program is it only for GAUSS 18. Are there some modifications to run it on Gauss 10?

Also, can you help me to identify the meaning of 8,4 in the first row? is it changeable?

new; format /rd /m1 8,4; output file= invest.out on;
tstart = date;
load invest; // Load data and define variables

t = 15;
nt = rows(invest);
n = nt/t;

y = invest[.,1]; @ investment/assets @
Tq = invest[.,2]; @ Tobin's Q @
c = invest[.,3]; @ cash-flow/assets @
d = invest[.,4]; @ debt/assets @


4 Answers


  1. I would expect the program to run in GAUSS version 10 without a problem. If you are having a problem, you can post a question which tells exactly what you did and exactly what error you are getting.

  2. The 8,4 is part of the format statement. It only controls the format for printing of numbers in the output report. These numbers tell GAUSS to give each number 8 digits worth of space and to print 4 numbers after the decimal point like this:
 -0.3419   0.8611
 -4.2066  -0.9677


thank you for your response.

Actually, I run my modified program and  I always obtain the same error :

Line 47 in C:\Users\fayrouz\AppData\Local\Temp\transtmp3
Operand missing G0064
Line 47 in C:\Users\fayrouz\AppData\Local\Temp\transtmp3
Syntax error G0008 : 'exp = fff[.,7]'
Closing: C:\Users\fayrouz\AppData\Local\Temp\transtmp3


Also when I run the program of the authors  I obtain  results that could not match  with those reported in the paper.

that's why I was asking about the version of Gauss, maybe the program is designed for gauss 18 and there is a  changes to run it on gauss 10.



Since the file in which the error is located is in a temporary directory and the filename is 'transtmp3', I think that your problem may be because you have the 'Dataloop Translation' turned on.

I don't remember where the 'Dataloop Translation' setting is located in GAUSS version 10, but check under the 'Tools' menu. You should find a checkbox to turn 'Dataloop Translation' on or off.


I don't know why i got this error, in my knowledge this is the part of program of seo and shin that i can't modified. please can you help me.


Line 256 in C:\Users\fayrouz\Desktop\prog modifié Fairouz.prg
Nested procedure definition G0155
Line 256 in C:\Users\fayrouz\Desktop\prog modifié Fairouz.prg
Syntax error G0008 : 'proc weight(n,t,de,w,t0)'
Closing: C:\Users\fayrouz\Desktop\prog modifié Fairouz.prg


the line 256 in the program is in bold:

/* input:
de: residuals
w : IV's

proc weight(n,t,de,w,t0); // with given residuals
local v,vbar,i,dei,wi,iv;

You must login to post answers.

Have a Specific Question?

Get a real answer from a real person

Need Support?

Get help from our friendly experts.

Try GAUSS for 14 days for FREE

See what GAUSS can do for your data

© Aptech Systems, Inc. All rights reserved.

Privacy Policy