GAUSS Editor and Autocompletion function

So I have noticed that my GAUSS program's autocompletion function is not working in the source window.

Also, the different element in the text (such as parentheses, equal sign, commands, ...) are not differently colored. I have checked and messed with the preferences for the source window, but it appears like it hasn't made a difference. I was wondering if you might be able to help me.

1 Answer


File Extension:
Look at the extension of the file you're editing on the source page. The internal logic of GAUSS will only enable the autocomplete and syntax highlighting for files that GAUSS recognizes. For example .lcg, .txt, .csv, .html, files will have no autocomplete or lexing enabled.

Rename the file to .e or .gss and open it in GAUSS to see if this enables the features you're looking for.

If you have the file currently open in GAUSS, can you please do the following:

1. Select the file menu and select "Save As"
2. Add the extension .gss to the existing filename.

You might need to close and reopen the file but you can verify prior to closing if the editor picked up the renaming.

You can also rename files from the Project View widget on the source page.
- Right click in the Project View and select "Add folder"
- You can add the folder where the file is located.
- If the txt file is not visible please right click in the Project View widget and unselect "Filter GAUSS files".
- From here you can right click the txt file and select the "rename" context menu item.

You must login to post answers.

Have a Specific Question?

Get a real answer from a real person

Need Support?

Get help from our friendly experts.

Try GAUSS for 14 days for FREE

See what GAUSS can do for your data

© Aptech Systems, Inc. All rights reserved.

Privacy Policy