Dynamic seemingly unralated regression, DSUR of Mark et al (2005)

Hi, I recently downloaded the Gauss light 17. Please, can Gauss light run the DSUR codes of Mark et al (2005)? I tried running the codes but it's giving me an error message. Do I need to install some application modules before running the codes? If yes, what application modules do I need to install? The codes and data are found here,  http://www.utdallas.edu/~d.sul/papers/Recent%20Working%20Papers1.htm   (item number 23).

Thank you.

7 Answers


Could you post the exact error messages that you are getting?


Thank you so much for your reply. Sorry there was a mix up in the message I sent earlier. I actually got the error message from Gauss 6 not the Gauss light. Below is the error message;

(0) : error G0290 : '' : library not found
(0) : error G0455 : '#include pdols.prg' : Cannot compile source code
(0) : error G0455 : ' #include dsur.prg' : Cannot compile source code

However, I also could not a open the data with Gauss light. I got this message "The file could not be loaded. the file could be corrupt or not supported. if you believe this to be an error please contact Aptech systems".

Thank you.



In the error message that you posted, the zero in parentheses is the line number of the error. A line number of zero means that the code was run in the GAUSS command input window. Therefore it looks like your first problem is that you need to run your main GAUSS file, rather than pasting it into the command prompt. You can run a file by entering

run name_of_file

at the GAUSS command prompt, or by opening the file in GAUSS and using the run buttons on the main GAUSS toolbar.

Your second problem is related to a library file. For us to help you with that, please post the line of code using the library statement. It will be something like

library comt;

and also tell us if there are any files with a .lcg file extension that were in your download.


Thank you so much for your reply. I got the error message below when I used the 

run name_of_file command. I do not have any file with .lcg file extension. Thank you.

» run dsur.prg;
(0) : error G0290 : '' : library not found
File not found: dsur.prg
» run start.prg;
(0) : error G0290 : '' : library not found
File not found: start.prg


I got a different error message when I ran the command  'run dsur.prg' using the Gauss light. Below is the error message

G0014 : File not found 'dsur.prg'

Thank you.


I downloaded the code to take a look. You are not supposed to run the file dsur.prg. That file contains procedures that are used by the main program. It appears to me that the file you are supposed to run is start.prg. Before you run it, make sure that your GAUSS working directory is the directory which contains the dsur files. Then enter: run start.prg. It will ask you some questions and you can enter your responses in the GAUSS command window.

I was able to get some of the combinations of options to work, but not all. It may be that they are not compatible and do not make sense. We can ask the author if you have a particular problem.


Thank you so much for your reply I really appreciate your help. I have a problem I want to solve with it, to be specific, I want to estimate a cointegrating equation with the DSUR. This is very important to me because it forms part of my research work. I will be gratefull if there is a way you can assist with that.

Thank you.

You must login to post answers.

Have a Specific Question?

Get a real answer from a real person

Need Support?

Get help from our friendly experts.

Try GAUSS for 14 days for FREE

See what GAUSS can do for your data

© Aptech Systems, Inc. All rights reserved.

Privacy Policy