Undefined Symbols for "lngam" and "cholsq"


I am trying to run Frank Schorheide (2011) "Bayesian Econometrics" Gauss Program for Reduced-VAR illustration 2.1. When I run the vm_mdd.g , the error turns out the undefined symbols for "lngam". Actually, "Ingam" means inverted-gamma distribution and I guess the problem may results from the absent of procedure or .src of "Ingam" which should be in the My Gauss library. However, I couldn't find this "Ingam" program on the internet. The same problem occur in vm_postdraws due to absence of "cholsq".


/* compute constants for integrals


do until i > nv;


nvar = cols(S);
C = cholpsd(inv(S))';
Z = C*rndn(nvar,v);
W = Z*Z';
IW = inv(W);


Do you know how can I get these program or procedure?


Zhu Zixiang

2 Answers


I think the procedures that you are missing are included in the "Additional Library Files" folder from the zip file on Dr. Schorfheide's site. To resolve your problem, you can either:

#include option
Copy the file dsgesel.src to the same directory as vm_mdd.g and add the line:

#include dsgesel.src

after the other #include statements towards the top of dsgesel.src.

Library option
Or you can add the dsgesel.src file to your GAUSS user library (user.lcg).

  1. Open the GAUSS Library Tool, by selecting View->Library Tool from the GAUSS Source Page main menu bar.
  2. If you do not already see the 'user' library in the list of libraries, create it by clicking the + icon next to 'Create Library' at the top of the Library Tool Window.
  3. Once the 'user' library is created, click the wrench icon next to 'user.lcg' and select 'Add Files'. Then browse to locate and select the file(s) that you would like to add to the library ('dsgesel.src' in this case).

It indeed works! Thanks a lot!

You must login to post answers.

Have a Specific Question?

Get a real answer from a real person

Need Support?

Get help from our friendly experts.

Try GAUSS for 14 days for FREE

See what GAUSS can do for your data

© Aptech Systems, Inc. All rights reserved.

Privacy Policy