xlsreadm command udefined symbols

User Forumxlsreadm command udefined symbols
jamesf473 asked 2 years ago


I am trying to load data into GAUSS from excel. I am using the commands xlsreadm, xlswrite, xlswritesa, xlsreadsa. I am getting the error:

Undefined symbols:

  • xlsreadm
  • xlswrite
  • xlswritesa
  • xlsreadsa

I have the file xls.src in the src folder, the commands are in the gauss.lcg and in the code I have included "library gauss;"

Can anyone help me with why the commands are not working?

Thank you


4 Answers
aptech Staff answered 2 years ago

The most likely answer is that there is either something wrong with your GAUSS library file (gauss.lcg) or something wrong in your configuration file (gauss.cfg).

1. The first thing I would try to do is to run your xls.src file by entering:

run xls.src

at the GAUSS command prompt. If this is successful, you should be able to use xlsreadm, xlswrite, etc until you use the GAUSS new command which clears out you symbols.

2. If that is successful, then try a basic XLS command. For example:

x = { 1.1, 2.2, 3.3, 4.4 };
xlsWriteM(x, "testfile.xls", "A1", 1, "");

3. If the command: run xls.src fails, then most likely your xls.src file is in the wrong place OR the src_path variable in your gauss.cfg file is pointing to the wrong place.

If your GAUSSHOME directory is C:\gauss14 for example, then your xls.src file should be in C:\gauss14\examples. And your src_path variable inside of gauss.cfg should contain an entry pointing to this directory. Something like:

src_path = $(GAUSSDIR)/src

In the statement above, $(GAUSSDIR) stands for your GAUSS installation directory (also known as GAUSSHOME).

Aptech Staff answered 2 years ago

It certainly could be related to what the other poster said. However, I think the problem is related to your compile preferences. If you have "Autoload" and "Autodelete" OFF, then you will get this error of undefined symbols for the "xlsreadm", etc.

For GAUSS 14, you can find these settings as check boxes. From the main GAUSS menu Select Tools->Preferences->Advanced. On that window you will find the check boxes for "Autoload" and "Autodelete".

jamesf473 answered 2 years ago

Thank you for the replies.

Strangely enough it appears that the problem goes away when I use a PC. I'm not sure if it is not a Mac problem, but it seems likely.

aptech Staff answered 2 years ago

Reading and writing of Excel files was not supported on Mac until GAUSS version 13. If you were running a version older than that on Mac, you would get an error of "undefined symbols".